Issues with some organization budgets

Major incident Growth User Acquisition
2023-02-23 13:47 UTC · 1 hour, 46 minutes

Updates

Resolved

We have recovered the issue with organization budgets and all campaigns are working normally again.

February 23, 2023 · 15:34 UTC
Investigating

Due to an internal migration bug some advertisers can observe their campaigns have been paused. We’ve identified the issue and the fix will be deployed in about an hour or two. Hold on, we’re on it

February 23, 2023 · 14:15 UTC
Issue

We’ve identified an issue which is currently affecting some acquire customers. We are investigating this now.

February 23, 2023 · 13:48 UTC

← Back