Matchmaker Incident

Major incident Multiplayer Matchmaker
2023-03-02 13:12 UTC · 30 minutes

Updates

Resolved

Incident is now resolved

March 2, 2023 · 13:42 UTC
Monitoring

Matchmaking is recovering.
We will keep monitoring the situation

March 2, 2023 · 13:35 UTC
Issue

Matchmaker is experiencing an issue at the moment preventing ticket from being matched together.
Our teams are investigating the issue

March 2, 2023 · 13:13 UTC

← Back