Temporary reduction in ads serving

Minor incident Growth User Acquisition
2023-04-01 10:15 UTC · 8 hours, 34 minutes

Updates

Resolved

This incident has been resolved.

April 1, 2023 · 18:49 UTC
Investigating

Temporary reduction in ads serving has been identified and is being investigated. No user action needed

April 1, 2023 · 16:27 UTC

← Back