Dashboard hangs when switching Organizations

Minor incident Websites Unity Dashboard
2023-04-18 15:10 UTC · 1 hour, 1 minute

Updates

Resolved

The incident has been resolved, we have confirmed platform stability. If you are still seeing issues, please contact our support team.

April 18, 2023 · 16:11 UTC
Investigating

An issue has been identified causing the Unity Dashboard to hang when switching between Organizations a user has access to.

The source of the issue has been found and a fix is expected shortly.

April 18, 2023 · 15:10 UTC

← Back