invalid certificate for id.unity.com in EU

Major incident Websites Unity Dashboard Unity ID/Login Unity Store Asset Store
2023-07-22 23:59 UTC · 20 hours, 24 minutes

Updates

Resolved

certificates have been updated in EU and validated from a number of EU locations to be working as intended

July 23, 2023 · 20:22 UTC
Issue

login to id.unity.com is known to not be working in the Europe region due to an expired certificate. Other regions are unaffected

July 23, 2023 · 18:41 UTC

← Back