UGS Analytics - Data processing incident

Minor incident Analytics Gaming Services Data Collection
2023-09-19 11:00 UTC · 3 days, 49 minutes

Updates

Resolved

The engineering team has identified and resolved the cause of the data ingestion incident that impacted UGS Analytics events received between 12:05 UTC to 17:12 UTC on Tue 19th Sep 2023

Unfortunately it is looking like the missing events from the incident cannot be recovered.

Apologies for the inconvenience that the missing data has caused

September 22, 2023 · 11:43 UTC
Update

We have identified the cause of the missing analytics data as a bug in our collection code causing a loss of collected analytics data between 12:05 UTC to 17:12 UTC. on 19th of September 2023.

Going forward we have identified the root cause and will be releasing a fix shortly. We also have put in place a backup plan so that there wouldn’t be any loss for future data ingestion should such an occurrence ever be reproduced.

The reports will be skewed on these dates because of this loss. Apologies for the inconvenience. We thank you for your understanding.

September 21, 2023 · 19:03 UTC
Investigating

Engineers are investigating a data processing incident relating to missing analytics event data between ~12:00 - 17:00 UTC on 19th Sep. Reporting and data analysis on players and gameplay during this period may not be accurate.

Further information will be posted on the as soon as we know more.

Event collection and processing is running normally at the moment, this incident relates to a period of ~5 hours on the 19th.

Apologies for any inconvenience.

September 20, 2023 · 15:15 UTC

← Back