Active outage impacting Unity Editor license verification and Unity ID logins

Major incident Websites Unity Dashboard Unity ID/Login Unity Store Publisher Portal Asset Store Editor Services Licensing
2023-11-07 19:38 UTC · 3 hours, 59 minutes

Updates

Resolved

Incident has been resolved with all services restored.

November 7, 2023 · 23:37 UTC
Investigating

We are seeing high error rates that are impacting Unity Editor license verification and Unity ID logins. The team is investigating the root cause.

November 7, 2023 · 19:38 UTC

← Back