Issues logging into Unity services

Major incident Websites Unity Dashboard Unity ID/Login Editor Services Licensing
2023-11-13 20:56 UTC · 2 hours, 15 minutes

Updates

Resolved

This incident has been resolved.

November 13, 2023 · 23:10 UTC
Investigating

We are aware of an issuing with users logging into the Unity Editor, Dashboard and additional services. We are actively investigating the issue.

November 13, 2023 · 20:56 UTC

← Back