Unity ID is down, Unity Hub and Unity Cloud also affected

Minor incident Websites Unity Dashboard Unity ID/Login
2023-12-14 11:41 UTC · 2 hours, 36 minutes

Updates

Resolved

The issue has been resolved.

December 14, 2023 · 14:17 UTC
De-escalate

The services are recovering and the issues are gone. We are still monitoring the situation to ensure smooth operations.

December 14, 2023 · 12:44 UTC
Investigating

Currently we know that:

  • id.unity.com is down
  • one cannot log in to the Unity Hub or Unity Cloud (cloud.unity.com)
  • users who are logged into Unity Cloud cannot create or update projects or organizations and their members
December 14, 2023 · 11:58 UTC
Issue

We are having issues with Unity ID that is impacting login to many of our products, including Unity Hub and Unity Cloud dashboard. The team is actively working on resolving the issue. We apologize for the troubles

December 14, 2023 · 11:41 UTC

← Back