Technical issue impacting Unity Ads

Major incident Growth User Acquisition
2024-02-14 18:40 UTC · 4 hours, 53 minutes

Updates

Resolved

Traffic is back to normal and incident is resolved.

February 14, 2024 · 23:32 UTC
Monitoring

Incident cause is identified and traffic is starting to return to normal.

February 14, 2024 · 23:19 UTC
Issue

We are currently experiencing a drop in traffic. We are investigating the issue.

February 14, 2024 · 18:40 UTC

← Back