Login with Facebook not working

Minor incident Websites Unity ID/Login
2024-06-12 17:31 UTC · 1 month, 1 week, 3 days, 2 hours, 17 minutes

Updates

Update

We are working with our partners at Facebook to resolve the issue. For the time being, please use your email and password to log in. We apologize for the inconvenience!

July 22, 2024 · 08:38 UTC
Investigating

Login with Facebook is currently not working. We are looking into the issue and will update you as we get more details.

June 12, 2024 · 17:31 UTC

← Back