Multiplay Platform Instability

Major incident Multiplayer Multiplay Multiplay Datacentres Game Server Hosting (UDash) Statistics
2024-08-06 22:20 UTC · 1 hour, 16 minutes

Updates

Resolved

After observing platform stability at 23:05 UTC, we have resolved the incident causing instability and player impact at this time. We are continuing to monitor closely for any further issues.

August 6, 2024 · 23:35 UTC
Issue

We are seeing platform instability at several locations for the Multiplay platform. We are working to resolve this as quickly as possible and will provide updates as we work towards a resolution. We apologize for any inconvenience regarding this outage.

August 6, 2024 · 22:20 UTC

← Back