Unity Checkout

Major incident Websites Unity Store Asset Store
2024-08-12 16:53 UTC · 18 hours, 39 minutes

Updates

Resolved

The Assetstore and Unity.com shopping cart are now back to normal.

August 13, 2024 · 06:35 UTC
Update

We have identified that one of our partner’s service is experiencing intermittent failures which leads to errors while trying to checkout shopping carts on AssetStore and Unity.com.

August 12, 2024 · 20:23 UTC
Investigating

We’re investigating an error happening to most users when trying to checkout their cart on Assetstore and Unity Store.

August 12, 2024 · 16:53 UTC

← Back