Some users experiencing errors and increased latencies

Major incident Websites Unity Dashboard Unity ID/Login Publisher Portal Asset Store
2024-10-08 10:59 UTC · 2 hours, 13 minutes

Updates

Resolved

The incident has been resolved. We identified a networking issue that was addressed.

October 8, 2024 · 13:10 UTC
Investigating

We are observing some users experiencing errors and increased latencies across our services. Users will notice increased loading times and potential errors on Unity Dashboard and Unity ID login. We are diligently working on addressing the issue! We apologize for the inconvenience.

October 8, 2024 · 10:59 UTC

← Back