Login with Apple ID is not working

Minor incident Websites Unity ID/Login
2024-10-10 18:39 UTC · 19 hours, 23 minutes

Updates

Resolved

The team has resolved this issue and login with apple id should be fully functional.

October 11, 2024 · 14:01 UTC
Investigating

Login with Apple ID is not working, our team is looking into it.

October 10, 2024 · 18:39 UTC

← Back