Emails are not being sent to users

Major incident Websites Unity Dashboard Unity.com Unity ID/Login
2024-11-25 14:25 UTC · 42 minutes

Updates

Resolved

The issue has been resolved.

November 25, 2024 · 15:07 UTC
Issue

Transaction emails related to 2fa, invites and other general user notifications currently cannot be sent out to end users.

We are looking into the issue and will work on resolving this as soon as we can.

November 25, 2024 · 14:25 UTC

← Back