Users unable to complete purchases on checkout flow

Major incident Websites Unity Store
2024-11-29 14:35 UTC · 2 days, 18 hours, 55 minutes

Updates

Issue

Summary

There was an impact on the checkout flow that prevented users from completing purchases.

Update

We mitigated the incident on Monday Dec 02 9:30am UTC. We are working to improve monitoring and testing processes to prevent similar issues in the future.

If you are still seeing issues, please contact our support team.

December 2, 2024 · 17:30 UTC

← Back