Increased latency on some Asset Store pages
Minor incident
Websites
Asset Store
2025-02-28 18:38 UTC
· 1 hour, 23 minutes
Updates
Resolved
February 28, 2025 · 20:01 UTC
We have confirmed platform stability and consider this incident resolved. If you are still seeing issues, please contact our support team.
De-escalate
February 28, 2025 · 19:47 UTC
We’re seeing stability across our platform and are monitoring.
We’re continuing to look into the cause of the issue.
Investigating
February 28, 2025 · 18:38 UTC
We’ve identified an issue which is currently affecting latency on some Asset Store pages. We are investigating this now.
← Back