Dashboard page performance

Minor incident Analytics Gaming Services Dashboards and Reporting LiveOps Remote Config Push Notifications
2025-03-03 14:51 UTC · 19 hours, 51 minutes

Updates

Resolved

The performance issue was resolved on Mon 4th; overnight monitoring has not identified any further performance issues.

March 4, 2025 · 10:41 UTC
Investigating

The issue that was causing dashboard page load and audience evaluation delays has been resolved. Engineers are monitoring performance to ensure everything returns to normal.

March 3, 2025 · 16:57 UTC
Investigating

Engineers are continuing to investigate this issue and have escalated the priority.

Further updates will be posted here, apologies for the inconvenience.

March 3, 2025 · 16:37 UTC
Monitoring

We are currently experiencing performance issues which are causing delays in the population of some Analytics and Push Notifications dashboard pages.

Please note that the ingestion and processing of Analytics data is not impacted; this is just a dashboard page loading issue.

Apologies for the inconvenience, further updates will be posted here as we work to resolve the incident.

March 3, 2025 · 14:51 UTC

← Back