Delay in Cost & Usage Reporting Page

Minor incident Analytics Gaming Services Dashboards and Reporting Unity DevOps Unity Build Automation Cost & Usage Reporting Unity Version Control Cost & Usage Reporting Unity Cloud Automation Cost & Usage Reporting
2025-03-28 20:00 UTC · 2 days, 22 hours

Updates

Update

Incident resolved

March 31, 2025 · 18:13 UTC
Issue

We are currently experiencing an incident that is causing delays in the display of metered billing usage data on the dashboard.
Our team is actively working to resolve the issue, and we will provide updates as soon as possible.

March 31, 2025 · 17:22 UTC

← Back