History & Performance page outage
Minor incident
Growth
User Acquisition
2025-04-16 20:00 UTC
· 11 hours, 45 minutes
Updates
Resolved
April 17, 2025 · 07:45 UTC
We identified the issue and fixed it. The History & Performance page is working normally again.
Investigating
April 17, 2025 · 07:01 UTC
The History & Performance page on Unity User Acquisition dashboard is currently unavailable due a technical problem. Our team is investigating the issue and working to resolve it as soon as possible. Other dashboard features are not affected. Sorry for the inconvenience.
← Back