Multiplay Hosting servers reporting incorrect CPU utilization

Major incident Multiplayer Multiplay Game Server Hosting (UDash)
2025-04-24 18:51 UTC · 1 hour, 13 minutes, 1 second

Updates

Resolved

We have deployed the fix to all affected servers and are confident of platform stability. We will continue to monitor for any further issues, but we consider this incident resolved now.

April 24, 2025 · 20:04 UTC
Investigating

We have identified the issue within our systems and are in the process of deploying a fix to all affected servers.

April 24, 2025 · 19:44 UTC
Issue

We are currently investigating an issue affecting Multiplay Hosting with Linux servers incorrectly reporting CPU usage causing them to crash.

April 24, 2025 · 18:51 UTC

← Back