Incomplete stats reporting
Minor incident
Multiplayer
Multiplay
Statistics
2025-05-14 16:51 UTC
· 1 hour, 9 minutes
Updates
Resolved
May 14, 2025 · 17:58 UTC
We have confirmed stability with stats reporting correctly since 16:45 UTC. At this point we consider this incident to be resolved.
Issue
May 14, 2025 · 16:51 UTC
We have identified an issue recording incomplete stats from a small number of environments starting at 14:25 UTC. This did not impact players but did impact the visibility of player counts in the affected environments.
We have resolved the stats reporting issue at approximately 16:45 UTC and we are continuing to investigate.
← Back