Cloud Save query performance degraded
Minor incident
LiveOps
Cloud Save
2025-05-15 10:43 UTC
· 21 hours, 49 minutes
Updates
Resolved
May 16, 2025 · 08:24 UTC
The issue has been identified and resolved.
Data updated during the incident period (we believe beginning at 2025-05-14 13:22 BST and ending 2025-05-15 23:38 BST) may not have been added to indexes and therefore may not be available for querying but all data moving forward should perform as expected.
We apologize for any inconvenience this has caused.
Investigating
May 15, 2025 · 10:43 UTC
The engineering team is currently investigating an issue with Cloud Save where queries are not returning all the expected data.
We will provide updates as they are made available.
← Back