Build Licenses are not activating or renewing

Major incident Editor Services Licensing
2025-06-04 16:07 UTC · 6 days, 6 hours, 57 minutes

Updates

Resolved

Infrastructure updates resulted in a load balancer becoming unhealthy. The faulty infrastructure has been replaced and the systems have been stable for several hours.

June 10, 2025 · 22:56 UTC
Monitoring

We have identified the source of the performance degradation and mitigated the issue. We will continue to monitor the system health.

June 10, 2025 · 19:42 UTC
Investigating

We are investigating a performance issue which is impacting build license activation and renewal functionality.

June 10, 2025 · 15:00 UTC
Investigating

It looks like the issue is affecting both floating licenses and legacy build licenses, which is causing issues in custom build systems.

June 10, 2025 · 13:53 UTC

← Back