Latest reporting data unavailable

Minor incident Grow Ads Unity Ads Unity Acquire
2025-06-12 06:34 UTC · 5 hours, 27 minutes

Updates

Resolved

The reporting data processing is working normally again and all missing data has been recovered. Sorry for the inconvenience.

June 12, 2025 · 12:01 UTC
Update

Our data processing partner has rolled out a fix to their service. We are now working to restart our data processing pipelines to process the missing data. No ETA yet on full recovery.

June 12, 2025 · 07:36 UTC
Investigating

We identified an issue with our data processing partner. The issue affects data since 12-06-2025 00:00 UTC. New reporting data for Unity Ads monetization and user acquisition is currently unavailable. Historic reporting data is not affected and is available normally.

We are working to resolve this issue as soon as possible.

June 12, 2025 · 06:34 UTC

← Back