Cloud provider outage

Major incident Multiplayer Relay Distributed Authority Lobby Matchmaker Friends
2025-06-12 18:12 UTC · 5 hours, 11 minutes

Updates

Resolved

Provider mitigations for affected services look stable. All internal service metrics looks good.

June 12, 2025 · 23:22 UTC
Monitoring

Provider mitigation has been applied

June 12, 2025 · 20:59 UTC
Issue

Major provider outage affecting service network

June 12, 2025 · 18:12 UTC

← Back