Ads requests significantly down due to GCP outage

Major incident Grow Ads Unity Ads Unity Acquire
2025-06-12 18:00 UTC · 5 hours, 23 minutes

Updates

Resolved

Unity Ads services caused by a Google Cloud Platform (GCP) outage has been resolved.

Ads traffic is now back to normal scale.

We sincerely appreciate your patience and understanding throughout this incident.

June 12, 2025 · 23:19 UTC
Issue

Due to GCP outage, we are seeing significant reduce on Ads requests for Unity Ads.

Team is working with GCP on updates.

June 12, 2025 · 18:29 UTC

← Back