Dashboard access limited due to GCP outage

Major incident Unity DevOps Billing Unity Build Automation Cost & Usage Reporting Unity Version Control Cost & Usage Reporting Cloud Diagnostics Integrations Grow Ads Websites Unity Dashboard Unity ID/Login Unity ID (legacy) Unity Login Unity Store Publisher Portal Asset Store Unity Discussions Unity Learn Unity Issue Tracker Asset Manager Asset Transformations Unity Cloud Automation Cost & Usage Reporting Levelplay Platform Ad Quality Platform ironSource Ads Platform Unity Ads Unity Acquire Tapjoy Supply Tapjoy Demand
2025-06-12 18:00 UTC · 7 hours, 26 minutes

Updates

Resolved

GCP incident has been resolved. Dashboard is up and running. User log in issue is resolved cross all platforms.

We appreciate your patience.

June 13, 2025 · 01:24 UTC
Issue

Due to current GCP outage, dashboard is down, access is limited. Impacting all functionalities

We are working with GCP to resolve the incident.

June 12, 2025 · 18:39 UTC

← Back