Unity Dashboard slow to load

Major incident Websites Unity Dashboard
2025-06-13 15:07 UTC · 35 minutes

Updates

Resolved

We have resolved the issue, everything should be back to normal.

June 13, 2025 · 15:42 UTC
Issue

We are experiencing issues with the Cloud Dashboard so it might not load for some users or be slow to load. The team is working on a fix and we should be back to normal soon.

June 13, 2025 · 15:07 UTC

← Back