Delay in project visibility on the dashboard.

Minor incident Analytics Gaming Services Data Collection Dashboards and Reporting Websites Unity Dashboard
2025-06-17 13:29 UTC · 6 hours, 15 minutes

Updates

Resolved

Back to normal operation for everyone.

June 17, 2025 · 19:44 UTC
Monitoring

We are experiencing a slowdown that is affecting the visibility of newly created projects on the dashboard. This may also affect any Analytics data collection for those new projects. Our team is actively working to resolve this issue, and we expect it to be cleared up within the next few hours. Thank you for your patience!

June 17, 2025 · 13:29 UTC

← Back