Unity Dashboard Access Temporarily Disrupted

Major incident Websites Unity Dashboard
2025-06-23 14:42 UTC · 33 minutes

Updates

Resolved

Unity Dashboard is available, the incident has been resolved.

Apologies for any inconvenience.

June 23, 2025 · 15:14 UTC
Monitoring

Unity Dashboard is available again. Engineers are continuing to monitor availability.

Apologies for the inconvenience.

June 23, 2025 · 15:12 UTC
Issue

We are currently investigating an issue causing errors when accessing the Unity Dashboard. Our team is actively working to identify the cause and resolve it as quickly as possible.

We’ll provide an update shortly. Thank you for your patience.

June 23, 2025 · 14:42 UTC

← Back