Unity ID Temporarily Disrupted

Major incident Websites Unity ID/Login Unity ID (legacy) Unity Login
2025-06-23 14:59 UTC · 18 minutes

Updates

Resolved

The network latency reduced to normal levels once the systems recovered after the fix to login was completed.

June 23, 2025 · 15:16 UTC
Investigating

Cause for elevated error rates was fixed. Our team is investigating issue with latencies following the fix.

June 23, 2025 · 15:10 UTC
Issue

We are currently investigating an issue with login systems. Our team is actively working to identify the cause and resolve it as quickly as possible.

Thank you for your patience.

June 23, 2025 · 14:59 UTC

← Back