Economy Service Down
Major incident
LiveOps
Economy
2025-06-25 05:45 UTC
· 2 hours, 14 minutes
Updates
Resolved
June 25, 2025 · 07:58 UTC
The root cause of the Economy Service outage has been identified and resolved.
The incident resulted in a partial outage of the Economy service, impacting a subset of games.
Apologies for the inconvenience.
Monitoring
June 25, 2025 · 07:54 UTC
Engineers have identified the issue and applied a mitigation. The Economy service is back up and running.
We are monitoring the Economy service and will provide further updates.
Apologies for the inconvenience.
Investigating
June 25, 2025 · 05:45 UTC
We have identified an issue with the Economy service. It is currently returning 500 error messages to requests.
Engineers are investigating.
← Back