Multiplay Hosting Signup Creation Unavailable

Minor incident Multiplayer Multiplay Game Server Hosting (UDash)
2025-07-31 01:00 UTC · 2 days, 10 hours, 15 minutes

Updates

Update

New account creations will occur as normal. We are seeing no impact with new sign ups. However, if you are still awaiting the activation of Multiplay after signing up within the past 48 hours, you will still experience the highlighted issue.

We are still investigating a resolution for impacted customers.

August 1, 2025 · 13:21 UTC
Investigating

Our teams are aware of the cause of the sign up activation issues, and we are still working hard to resolve this.

July 31, 2025 · 15:06 UTC
Issue

Multiplay Hosting signup creation is unavailable for new Multiplay users.

We are investigating an issue with subscription creation for Multiplay with the team responsible for activation and management of subscriptions within Unity.
At this time, we are not able to activate the creation of new Multiplay subscriptions.

We do apologise for the inconvenience this is causing.

This is not affecting users who already have live subscriptions and access to Multiplay Hosting

July 31, 2025 · 09:04 UTC

← Back