Scheduled Maintenance Update for MTU1XP from 2025-09-04 14:00 UTC to 2025-09-04 14:40 UTC

Scheduled maintenance Comms and Safety Vivox mtu1xp Domain
2025-09-04 14:00 UTC · 40 minutes

Updates

Resolved

Maintenance is now complete, stats and systems are returning back to normal.

Regards
Vivox Operations

September 4, 2025 · 14:39 UTC
Update

Maintenance is still underway, we will update when systems are back up.

September 4, 2025 · 14:26 UTC
Scheduled

We are planning to perform maintenance on your voice platform on Thursday, September 4th at 10:00 AM EST. The maintenance is expected to take less than 10 minutes. However, we will continue to monitor the voice platform for 1 hour. Players in channel will be affected during this time. Please reply to this email if you have any questions with regard to this planned maintenance. Thank you!

Sincerely,
Vivox Operations

September 2, 2025 · 21:49 UTC

← Back