Users cannot create new accounts on login.unity.com

Major incident Websites Unity ID/Login Unity Login
2025-09-02 21:00 UTC · 17 hours, 27 minutes

Updates

Resolved

The incident has been resolved.

September 3, 2025 · 14:27 UTC
Investigating

We are investigating an issue regarding user sign ups failing on login.unity.com. The team is working on getting the problem solved soon.

September 3, 2025 · 13:27 UTC

← Back