Issues with User Acquisition Reporting

Minor incident Grow Ads Unity Acquire
2025-09-30 06:58 UTC · 1 hour, 22 minutes

Updates

Resolved

We have fixed the issue that was affecting User Acquisition reporting dashboard. The page is working normally again with all features available.

Thank you for your patience.

September 30, 2025 · 08:20 UTC
Issue

We are investigating an issue with the UnityAds User Acquisition reporting dashboard. Currently some features of the reporting dashboard are unavailable.

This issue doesn’t affect ad delivery or performance. Other reporting views like History&Performance, Monetization reporting and the reporting APIs are unaffected.

Sorry for the inconvenience.

September 30, 2025 · 06:58 UTC

← Back