Asset Manager Storage Performance Degrade

Minor incident Asset Manager Asset Manager Data Streaming Asset Manager Storage
2025-10-02 17:13 UTC · 2 hours, 33 minutes

Updates

Resolved

We have confirmed platform stability and consider this incident resolved. If you are still seeing issues, please contact our support team.

October 2, 2025 · 19:45 UTC
Issue

We have spotted performance degrading in relation to file uploading / downloading with Unity Asset Manager.
Our engineering team is fixing the issue.

October 2, 2025 · 17:13 UTC

← Back