New Multiplay Game Server Hosting Customers Unable To Create Builds
Minor incident
Multiplayer
Multiplay
Game Server Hosting (UDash)
2025-10-05 17:03 UTC
· 1 hour, 16 minutes
Updates
Resolved
October 5, 2025 · 18:18 UTC
Our engineering team has released a fix, and service should now be restored to normal.
Issue
October 5, 2025 · 17:03 UTC
New Game Server Hosting customers are experiencing inability to create new builds. We are actively investigating this concern and greatly appreciate your patience while we work to fix this service issue.
← Back