[Leaderboards] Player Names

Minor incident LiveOps Leaderboards
2025-10-09 09:58 UTC · 3 days, 20 hours, 49 minutes

Updates

Investigating

We are investigating reports of Leaderboards Player Names being changed to randomly generated replacements.

It is normal for new, unnamed players to be assigned a new, randomly generated name for Leaderboards to display. But existing player names should not be overwritten unexpectedly.

Initial investigation suggests that this may be impacting a subset of players during a 3-minute period around 19:10 UTC on 8th Oct.

Updates will be posted as the investigation progresses.

October 9, 2025 · 09:58 UTC

← Back