New Multiplay Game Server Hosting Customers Unable To Create Projects

Major incident Multiplayer Multiplay Game Server Hosting (UDash)
2025-10-16 06:56 UTC · 2 hours, 41 minutes

Updates

Resolved

The incident has now been resolved, and all services are operating normally. The disruption was caused by a partial degradation to a service affecting onboarding customers to the platform which has now been resolved.
We sincerely apologize for any inconvenience this may have caused and thank you for your patience and understanding as we worked to resolve this matter.

October 16, 2025 · 09:15 UTC
Issue

New Game Server Hosting customer are experiencing inability to create projects. We are actively investigating this concern and greatly appreciate your patience while we work to fix this service issue.

October 16, 2025 · 06:56 UTC

← Back