AWS Service Degradation Affecting Parsec

Major incident Parsec Parsec API Parsec Signaling Service
2025-10-20 07:49 UTC · 4 hours, 24 minutes

Updates

Resolved

All systems have returned to normal operation. The earlier impact caused by the AWS service disruption has been fully mitigated. Our signaling services and dependent components are performing as expected.

October 20, 2025 · 11:31 UTC
Update

AWS has reported that most affected services have recovered. However, we are still seeing residual impact on our signaling services due to delayed event processing in AWS Lambda and SQS.
A fix has been identified, and our engineering team is implementing it now to restore full functionality. We are monitoring closely and will provide another update once service performance has returned to normal.

October 20, 2025 · 11:06 UTC
Update

AWS reports significant recovery across affected services. Some operations may still experience minor delays as AWS processes a backlog of queued requests.
Our team continues to monitor system performance. We will provide another update once AWS declares the incident resolved or if we observe new impact.

October 20, 2025 · 09:32 UTC
Investigating

We are investigating an ongoing issue related to an AWS outage impacting multiple services. This outage may affect parts of our infrastructure that depend on these services. Our engineering team is actively monitoring the situation and working to mitigate customer impact.

October 20, 2025 · 07:49 UTC

← Back