AWS Service Degradation Affecting Multiplayer Clients

Minor incident Multiplayer Multiplay Multiplay Datacentres Statistics
2025-10-20 08:00 UTC · 5 hours, 33 minutes

Updates

Resolved

CCU has remained stable since 2025-10-20 10:05 UTC.

No sign of further impact.

October 20, 2025 · 13:33 UTC
Investigating

Gradual recovery seen from 09:21 UTC with stronger recovery from 10:08 UTC.

CCU is returning to normal levels for impacted clients.

October 20, 2025 · 10:12 UTC
Update

[Update]

AWS appears to be recovering. CCU is returning to affected customers utilising AWS services on their backend.
We are continuing to monitor to fully confirm.

October 20, 2025 · 09:24 UTC
Investigating

We are investigating an ongoing issue related to an AWS outage impacting multiple services. Our engineering team is actively monitoring the situation.

October 20, 2025 · 08:00 UTC

← Back