AWS Service Degradation Affecting LevelPlay and iAds Platform and External APIs

Major incident Grow Ads Levelplay Platform Real Time Pivot Reporting API Configuration API Ad revenue measurement API Rewarded video server-to-server callbacks Ad Quality Platform Impression Level API ironSource Ads Platform Reporting API Configuration API
2025-10-20 08:32 UTC · 2 hours, 3 minutes

Updates

Resolved

Issue has been resolved

October 20, 2025 · 10:35 UTC
Issue

We are investigating an ongoing issue related to an AWS outage impacting multiple services. This outage may affect parts of our infrastructure that depend on these services. Our engineering team is actively monitoring the situation and working to mitigate customer impact.

October 20, 2025 · 08:32 UTC

← Back