AWS Service Degradation Affecting Parsec

Minor incident Parsec Parsec API Parsec Signaling Service
2025-10-20 15:41 UTC · 7 hours, 24 minutes

Updates

Resolved

The incident is now resolved. Signaling, connection, and other related services are now fully restored. You may resume normal Parsec usage.

As a result of this resolution, some users may still see duplicate or “ghost” hosts in their applications that appear to remain online even though those computers are not active. Cleanup of these duplicate or “ghost” machines is ongoing and will not affect any other active, available computers moving forward. If you encounter any duplicate hosts before cleanup is complete and need to connect, you may attempt connections to each duplicate until you find the one that is successful. If you encounter a “ghost” host and attempt to connect, you may receive error code 6 implying that the host is not online and may be safely ignored until cleanup is complete. We apologize for any inconvenience this causes.

Additionally, a smaller subset of users may still see a warning banner persist that indicates degraded service, but this can be safely ignored. All incident related banner messages should disappear for affected applications in the next few hours according to predetermined polling windows for new updates. Once incident messages are removed, they will be replaced by our original downtime message, notifying users of our planned quarterly maintenance window.

Please note that our quarterly maintenance is still scheduled to occur on Saturday, November 1 2025.

A detailed post-mortem outlining incident discovery, triage, and resolution will be made available via this channel in the coming days. Thank you.

October 20, 2025 · 23:04 UTC
Update

Failover mitigations were successful. Connection services are now restored with other services gradually recovering. We will continue to monitor service health and update accordingly.

October 20, 2025 · 20:39 UTC
Update

While service improves, we’re still noticing significant AWS degradations impacting availability. With AWS IAM global services now restored, we’re implementing planned failover mitigations to resolve connectivity issues. We’ll continue to monitor and update accordingly.

October 20, 2025 · 20:06 UTC
Monitoring

We are continuing to experience degraded service availability and are our engineering team is actively monitoring the situation and working to mitigate customer impact. Further, we’ve confirmed that an AWS internal Lambda system has experienced ongoing errors, negatively impacting other systems. We’ve been informed that recovery is ongoing and we will report more updates as they’re received.

October 20, 2025 · 18:49 UTC
Issue

We are currently experiencing degraded service availability due to the previous reported ongoing AWS outage. Users may see intermittent connection errors. These errors should be resolved by retrying the request.

October 20, 2025 · 15:41 UTC

← Back