Allocation Failures
Major incident
Multiplayer
Multiplay
Game Server Hosting (UDash)
Matchmaker
2025-10-21 11:54 UTC
· 54 minutes
Updates
Resolved
October 21, 2025 · 12:48 UTC
Our engineering team have isolated the root cause of the issue affecting a minority of game server allocations and have applied a fix.
We are seeing a full recovery and will continue to monitor for any further issues.
Update
October 21, 2025 · 12:13 UTC
We can confirm that the issue was pinpointed and we’re seeing recovering.
We’re monitoring the situation for any further issues here.
Investigating
October 21, 2025 · 11:54 UTC
There is a new incident that is affecting some titles, disallowing allocations to be processed correctly.
We’re currently looking into the cause of this.
← Back