Unity Ads User Acquisition, Creative Management Operations Degraded
Minor incident
Grow Ads
Unity Acquire
2025-11-12 07:50 UTC
· 6 hours, 35 minutes
Updates
Resolved
November 12, 2025 · 14:20 UTC
Creative Management operations have remained stable following recent optimizations. The team will continue to monitor the situation.
Issue
November 12, 2025 · 08:16 UTC
We are seeing slow performance and delays with Creative Management features in Unity Ads User Acquisition. The team is investigating and working to resolve the issue.
Thank you for your patience.
← Back
Services Status