Parsec Degraded Performance
Minor incident
Parsec
Parsec API
Parsec Signaling Service
2025-11-18 14:45 UTC
· 4 hours, 3 minutes
Updates
Resolved
November 18, 2025 · 18:48 UTC
The incident is now resolved. Parsec signaling, connection, and other related services are now fully restored.
Monitoring
November 18, 2025 · 17:16 UTC
We are seeing signs of recovery and are monitoring the system performance.
Investigating
November 18, 2025 · 16:53 UTC
Once again we are noticing degraded service availability and our engineering team is actively monitoring the situation and mitigating customer impact.
Monitoring
November 18, 2025 · 15:42 UTC
We continue to see system recovery and will continue monitoring system performance.
Monitoring
November 18, 2025 · 14:49 UTC
We are seeing signs of recovery and are monitoring the system performance.
Issue
November 18, 2025 · 14:45 UTC
We are noticing degraded service availability and our engineering team is actively monitoring the situation and mitigating customer impact.
← Back
Services Status