Email notifications are delayed
Minor incident
Websites
Unity Dashboard
Unity ID/Login
Unity ID (legacy)
Unity Login
2026-01-15 15:21 UTC
· 22 hours, 50 minutes
Updates
Monitoring
January 15, 2026 · 18:48 UTC
The issue is fixed. We’ll keep monitoring the systems for now to ensure everything is fully resolved.
Issue
January 15, 2026 · 15:21 UTC
We are investigating an issue with email notifications for different actions such as user invites and 2FA being delayed.
← Back
Services Status